Audacity Tutorial

Skip to end of metadata
Go to start of metadata

Audacity Tutorial

Objectives

  • Understand how audio is stored digitally
  • Familiarize yourself with Audacity's editing tools
  • Learn how to use some of Audacity's effects (filters)
  • Learn how to create multi track sessions
  • Learn how to export and save Audacity tracks

Digital Sound

The way sound is stored in digital files is visually quite intuitive. Loading a sample into Audacity, you see an image of the waveform that makes up the sound. The height of the peaks and valleys corresponds to the volume of the sound at that particular point, and the distance between peaks shows us the frequency (or pitch) of the sound. Of course, tracks that contain multiple overlapping instruments or sounds will have very complicated waveforms that don't lend themselves to visual inspection for frequency.

In reality, the waveform that is stored in the computer is not as continuous as it looks. Fundamentally, computers are only capable of storing discrete numbers, not smooth wave shapes. However, the computer can simulate a smooth wave very well by sampling it at a very high rate. Sampling is the process of recording numbers that correspond to the amplitude (height) of the wave at various points time. By sampling the wave 44,100 times per second (for CD quality audio) the computer can convincingly replay a sound that seems natural to our ears. This is very similar to the process whereby films and television actually show us many distinct pictures each second, but our brains merge them into what looks like continuous motion.

Clipping

One danger created by sampling that you must always be aware of when working with digital audio is clipping. Clipping occurs when the amplitude (volume) of the sound wave at a given time is higher than the maximum number that your software is using to record volume. This causes the loudest parts of the wave to be "cut off" and is generally unpleasant sounding, similar in effect to when you speak too close into a microphone or shout too loud into your telephone.

You can tell when clipping is occurring during playback because you will see a little red mark appear next to your playback level meters in the toolbar. The red mark will persist even after you stop playing to remind you that clipping occurred on the last play-through. If you see this red mark appear, you should consider finding a way to lower the overall volume of your project at the point in time where it occurs. The best judge of clipping is always your ear though; occasionally, minor clipping will not be noticeable and you can safely ignore it.

Destructive and Non-Destructive Editing

When learning to edit audio, it can be helpful to think of each sample point as an individual letters in a long text document. Just like in Word, you can cut "letters" out and paste them to wherever you like. To continue the analogy, you can also affect the way those letters "look" by applying effects. Some effects don't change the actual data, or the sample points, themselves. This is called non-destructive editing. Examples of this are shifting the slider to the left of a track to increase its overall volume. However, many other effects do change the content, either subtly or radically. You can tell when this happens because you will see the shape of the waveform change when you apply these effects. If the actual sample points are changed, this is called destructive editing. Though this may sound bad, in actuality, this is a necessary part of audio editing. Destructive editing simply means that the original sample you've been working on has been changed. Audacity is a powerful program in that it utilizes many non-destructive editing techniques, usually allowing you to revert back to the original sound file either through a series of undos or by turning off certain editing effects. Applying many destructive effects in a row can have a negative effect on sound quality, so it's a good idea to keep track of them as you apply them, and make sure you're only using ones you really need.

Basic Tools and Editing

Selecting


The six basic editing buttons are next to the play buttons: Selection, Envelope, Draw, Zoom, Timeshift, and Multitool. Just like in Word, Audacity comes with a cursor which you can use to highlight portions of the audio sample. Simply click the selection tool on the Controltoolbar and click and drag across your audio sample; the grayed area you've selected is now subject to any number of editing tools or effects. Selecting portions of audio is also effective if you wish to listen intensely to certain portions of your sample. After selecting your intended sample, click the Play button. To unselect, click once inside your audio track. To quickly select the entire audio track, simply click inside the side panel of the audio track. To select every track in your project, go to Edit > Select > Select All.
 
 

Zooming

Use the magnifying glass located on the control toolbar to zoom in and out of specific parts of your audio sample. Left-click once to zoom in on a section, or right-click to zoom out. To zoom into a specific part of your sample, left-click and drag across a portion of your audio sample. The section you've selected will now completely fill up your window.

Envelope


The envelope tool, found on the Control toolbar, is useful for manually adjusting the loudness of any portion of your sample without actually affecting the sample itself, an example of non-destructive editing, at least until you export it. However, so long as you continue saving the file as an Audacity project, you will always be able to change the audio sample back to the original way it sounded. Envelopes are especially useful for editing interviews; if one person is consistently louder than the other, lower the louder person's voice by creating envelope "handle" points around each loud portion, and lower the volume level. You can alter the dynamics of your waveshape with the Envelop function. The open dots on the blue line represent the "handle" points and are draggable.

After turning the envelope tool on, blue borders will now surround your sample. Click at any point on the blue line to add a handle, symbolized by a white square point. Once you have added more than one handle, you can change the how loud the sound is between two handles. Widen the blue border to increase the volume between those points, and vice versa, narrow the blue border to decrease the volume. To remove a handle point, simply click and drag it off the track.
 
 

Multi-tool

The multi-tool button allows you to perform multiple editing actions with your mouse. Clicking on multi-tool activates, among other things, the envelope tool described above. You can now adjust volume levels by adding handles and moving them. You can also select sections of your audio sample with the I-beam selection cursor. Finally, you can also zoom into your sample by right-clicking and dragging to select the sample you wish to see, or you can right-click once to zoom out.

Timeshift

Timeshift, located on your Control toolbar, is a faster way to cut and paste an entire track; after selecting timeshift from the toolbar, click and drag left and right in the audio track window to move the sample earlier or later, thus adding or eliminating silence to the beginning of the track.

Cut / Copy / Paste

The cut, copy, paste, trim, and silence buttons are clickable for your convenience.
Just like in a word processor, you can cut or copy portions of your audio sample and paste them in a different place within your audio file or in a new audio file altogether. First select the portion of the audio you wish to affect, then use either the toolbar buttons for cut and copy or use the Edit menu. Then click your cursor on the location you wish to insert the audio, and click paste.
 

 

Delete / Trim

Click and drag to select the portions of audio you wish to remove and then hit the Delete button or Edit > Delete. If instead, you wish to "crop" that selected portion, meaning you wish to keep only the selected portion and delete everything else, use Edit > Trim.

Silence

Silence is different from deleting in that deleting removes not only the selected "sound" in an audio file, but it also removes the time/space that it took up. Silence leaves the time gap within the track, but changes the volume of the selected area to zero.

Meters / Mute

Meters are available on the side and to the top of your waveshape. With these, you can change the input or output volume as well as the panning.
 

There are numerous meters and levels located on the side panel of each track and at the top of your screen which control the volume, or gain, of the track which is played out. However, none of these directly affect the physical sample until you export the track. Simply slide the levels left and right to alter the level of sound from each track.
The meters are especially useful for detecting clipping---that is when your audio file is too loud to be accurately played back. If your audio sample is clipping, a red indicator will turn on to the right of your sound meters. If this occurs, try and go back and re-record with your microphone level turned down.

Clicking the mute button will silence that track during playback. This way you can listen to other tracks without being distracted by others. But don't worry! You haven't deleted the track. Simply click the mute button once more to listen to it during playback.

The solo button is simply a fast way of muting every other track except the one you want to listen to. If you need to focus on one track, instead of muting every track you don't want to hear, hit the solo button and hit play.

Basic Effects

Normalize

If you wish to standardize all your tracks so that they are all as loud as possible, select and go to Effect > Normalize. The defaults should be fine. The great thing about Normalize is that it will never make your sample so loud as to introduce clipping and distortion, so feel free to safely use this effect to quickly increase the volume of soft tracks.

Fade in / Fade out

Fade in and fade out do exactly as they say; respectively, they gradually increase or decrease a sound based on the length of track you've selected. For Fade-in, the track will start at zero and gradually increase while fade-out is the exact opposite. After selecting what you wish to be faded, go to Effect > Fade In or Fade Out. Use these to smoothly segue (as least volume-wise) into different tracks.

Tempo / Pitch / Speed

Pitch is related to frequency. Pitch is the high or low tone we hear in any piece. By decreasing the time between crests, one can increase the frequency and, therefore, the pitch. Doing so increases the speed since the time between crests is reduced. However, in Audacity, changing the pitch will not affect the speed of the piece since Audacity readjusts each track to maintain the original speed; similarly, one can increase the pace of the song in Audacity without noticeably changing the pitch using the Change Tempoeffect. However, if you do wish to change the speed and pitch, perhaps to simulate a record winding down, you can use Audacity's Change Speed effect, which will affect both tempo and pitch. Both Speed and Tempo changes will affect the overall length of your piece.

To apply any of these effects, select the track or portion of the track you want the filter applied to, then go to Effect > Change Pitch, Change Speed, or Change Tempo. From there, you will be given many advanced options, but the most important one is the percent change field. Inputting a percentage greater than zero will speed up or pitch up your track while a negative number will do the opposite.

Advanced Effects

Invert (stripping out vocals)

Invert simply takes your waveshape and turns it upside down. This may not make any audible differences when applied to a single track, but where this effect comes in handy is for when you wish to strip the vocals from a song---in effect create a karaoke track of only the instrumental lines. Clicking the upside down triangle on the name bar reveals a host of options.

 
This is possible because most songs place the vocals exactly in the center of a stereo mix of tracks. Therefore, if you split the a stereo audio track and then invert one of the tracks, the vocals in one track will cancel out the vocals in the other. Then you can mix the tracks back together and create a karaoke track. To do all of this:
 

  1. Go to the track name side panel and click the triangle drop down.
  2. Choose Split Stereo Track
  3. Select one of the audio tracks and go to Effect > Invert.
  4. Now change each track to Mono via the track name side panel so the centered vocals will get canceled out when played through the same channel.
     
     
     

Noise Reducer

If your track has an audible hiss or a repeated noise that you wish removed from throughout your track, use the noise reducer. Simply select a representative section of noise and go to Effect > Noise Removal. Click on Get Noise Profile so Audacity knows what to recognize as noise. Now select the whole track, go back to Effect > Noise Removal, and click Remove Noise.

Equalizer / Bass Boost

Like the equalizer on your radio, Audacity can change the volume of certain bands of frequencies, thus allowing you to make your treble more distinct, the bass more prevalent, or some combination of the two. The Bass Boost take the same concept of equalization and simply raises the bass levels on your song.

Go to Effect > Equalization to bring up the equalizer. Like with the envelope, you can create handle points and drag them up or down to increase or decrease the volume at that frequency.

Effect > Bass Boost brings up the menu or increasing the bass levels in a track. Fiddle with the options to manually specify the amount of bass to be added.

Reverb

Reverb is a type of subtle echo that occurs in all recorded music, but is most evident when the sound is recorded in a large room, like a cathedral or an auditorium. To simulate the effect of music being played in such an environment, one can add more reverb to a sample. However, even if one doesn't wish to achieve such a live music effect, adding even minor amounts of reverb can make a sample sound warmer and more authentic, especially vocals.

After selecting the sample you wish to edit and going to Effect > Gverb, one is presented with numerous sliders. The options which control the G-Verb the most in our case are early reflection level and tail level. Early reflection level refers to the initial echo the sound makes as it bounces off the walls, while tail level refers to the continued echoing effect as that sound continues to reverberate. The higher you set these, the more spacious your sound becomes.

Reverb time controls the length of each series of reverberations while damping simulates the natural effect of sounds being absorbed in the walls. Try experimenting with these levels until you get a sound you like. To start with, try setting dry signal to 0 dB, early reflection level to -22 dB, and tail level to -26 dB. Make use of the preview button to try things out.

For more about the specific definitions of the options and some other good presets, check the Audacity wiki page about GVerb (_http://audacityteam.org/wiki/index.php?title=GVerbSettings_).

Compressor

The compressor effect reduces the dynamic range of a sound sample. The dynamic range is the difference between the loudest parts of the sound and the softest. Strictly speaking, compression alone makes the loudest parts of the sound softer, but typically additional gain is applied to the sound after compression, which makes the overall sound louder. Thus, the net effect of compression + gain is that the softer parts of the sound become louder. The most common use for this effect is to make drums sound "punchier," but it can also enhance the crispness of other sounds when used in moderation.

In the compressor window, threshold refers to the volume level above which you want the volume of your sounds to be reduced. The ratiois the amount those sounds above the threshold get reduced; a higher ratio will mean loud sounds will be dampened significantly and will sound more like the rest of the sample. Experiment and see what the best levels are for your sample.

Multi Track Sessions

One of the great features of Audacity is its ability to handle multiple tracks of samples at the same time. Thus, you can easily mix tracks together, line tracks up so certain parts segue properly, separate out channels in a song, and so forth.

Quick Mix

If you wish to physically merge the waveforms of multiple tracks into one track, simply select all the tracks you want to mix, then go to Project > Quick Mix.

Labels

Adding a label track is a great way to organize complex audio sessions. A label track doesn't actually contain any audio; instead, here you can store information about when things are happening in your other samples. For instance, you can remind yourself of when the vocals begin in the label track. To create a label track, go to Project > New Label Track. From there, place your cursor within the label track and go to Project > Add Label. You can then type in the description of what occurs at the cursor point.

Saving Projects

When you save an Audacity project, all of the tracks you've created will remain intact for further editing. If you know you'll need to continue editing your piece in Audacity, it's best to save a project version of it for yourself; otherwise, once you export the track as an MP3 or WAV, the program reduces the many tracks you have to only two at most, thus making future editing much more difficult since all the tracks have been mixed together.

Resources

Labels

student student Delete
staff staff Delete
faculty faculty Delete
how-to how-to Delete
tutorial tutorial Delete
audacity audacity Delete
digital digital Delete
audio audio Delete
editor editor Delete
sound sound Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.